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Abstract pegasus is a parton-level Monte-Carlo event
generator designed to calculate cross sections for a wide
range of hard QCD processes at high energy pp and p p̄
collisions, which incorporates the dynamics of transverse
momentum dependent (TMD) parton distributions in a pro-
ton. Being supplemented with off-shell production ampli-
tudes for a number of partonic subprocesses and provided
with necessary TMD gluon density functions, it produces
weighted or unweighted event records which can be saved as
a plain data file or a file in a commonly used Les Houches
Event format. A distinctive feature of the pegasus is an intu-
itive and extremely user friendly interface, allowing one to
easily implement various kinematical cuts into the calcula-
tions. Results can be also presented “on the fly” with built-in
tool pegasus plotter. A short theoretical basis is presented
and detailed program description is given.

1 Program summary

Title: pegasus 1.0
Computer for which the program is designed and others on
which it is operable: Linux systems
ProgrammingLanguage used:C++ and Fortran 77, compiled
with g++ and gfortran
High-speed storage required: No
Separate documentation available: No
Keywords: QCD, BFKL and CCFM evolution equations,
small-x physics, TMD parton densities, high-energy factor-
ization
Physical problem: Theoretical description of a number of
high energy processes proceeding with large momentum
transfer and containing multiple hard scales needs for trans-
verse momentum dependent (TMD) parton (quark or gluon)

a e-mail: lipatov@theory.sinp.msu.ru (corresponding author)

distributions in a proton [1–4]. These quantities encode the
nonperturbative information on proton structure, including
transverse momentum and polarization degrees of freedom
and satisfy the Balitsky–Fadin–Kuraev–Lipatov (BFKL) [5–
7] or Catani–Ciafaloni–Fiorani–Marchesini (CCFM) [8–11]
evolution equations, which resum large logarithmic terms
proportional to αn

s lnn s/�2
QCD ∼ αn

s lnn 1/x . At high ener-
gies (or, equivalently, at small x) the latter are expected
to become equally (or even more) important than the
conventional Dokshitzer–Gribov–Lipatov–Altarelli–Parisi
(DGLAP) contributions proportional to αn

s lnn μ2/�2
QCD

[12–15]. The CCFM equation takes into account additional
terms proportional to αn

s lnn 1/(1−x) and, therefore, is valid
at both small and large x .
Solution: Experimental investigations of hadron scattering
processes at high energy colliders, such as the Large Hadron
Collider (LHC), usually imply multiparticle final states and
implement complex kinematical restrictions on the fiducial
phase space. The multi-purpose Monte-Carlo event gener-
ators are commonly used tools for theoretical description
of the collider measurements. Most of them (for example,
pythia 8.2 [16], mcfm 9.0 [17], madgraph5_amc@nlo
[18], sherpa 2.2 [19], herwig++ 2.7.1 [20], powheg box
[21–23] and other) use conventional (collinear) QCD fac-
torization, which is based on the DGLAP resummation. On
the other side, the hadron-level Monte-Carlo event generator
cascade [24,25] and parton-level generator katie [26] can
deal with non-zero transverse momenta of incoming off-shell
partons. In particular, cascade, being supplemented with
off-shell amplitudes for the hard scattering subprocesses,
employs the CCFM equation for initial state gluon evolu-
tion. katie calculates the tree-level off-shell amplitudes for
arbitrary processes within the Standard Model (up to four
final-state particles) and uses tmdlib package [27] to access
the different sets of the TMD parton densities. pegasus is
a newly developed parton-level Monte-Carlo event genera-
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tor designed to calculate cross sections for a wide range of
hard QCD processes, which also incorporates the TMD gluon
dynamics in a proton. It provides all necessary components,
including off-shell (dependent on the transverse momenta)
production amplitudes and grid files for TMD gluon densi-
ties, interpolated automatically. pegasus offers an intuitive
and extremely user friendly interface, which allows one to
easily implement various kinematical cuts into the calcu-
lations. Generated events (weighted or unweighted) can be
stored in the Les Houches Event file or presented “on the fly”
with convenient built-in tool pegasus plotter.

The underlying physics in cascade, katie and pegasus
is basically the same. However, pegasus simplifies setting
the parameters and kinematic constraints (through the menu,
with no programming); it can switch between the collinear
and TMD modes; it provides a choice between weighted and
unweighted events; and it operates with a graphics interface,
which is detached in the console version (if a long-time calcu-
lation is needed). These features make pegasusmore flexible
and better adjustable to the user’s needs.
Restrictions on the complexity of the physical problem: The
following production amplitudes are implemented:

• g∗ + g∗ → Q + Q̄, where Q = c or b
• g∗ + g∗ → Q + b + c̄, where Q = Bc or B(∗)

c

• g∗ + g∗ → QQ̄
[

3S(1)
1

]
+ g → Q+ g, where Q = ψ ′,

J/ψ or ϒ(3S)

• g∗+g∗ → QQ̄
[

1S(8)
0 , 3S(8)

1 , 3P(8)
J

]
→ Q, whereQ =

ψ ′, J/ψ or ϒ(3S)

• g∗ + g∗ → QQ̄
[

3P(1)
J , 3S(8)

1

]
→ Q, where Q =

χcJ (1P) or χbJ (3P)

• g∗ + g∗ → H0 → γ γ

• g∗ + g∗ → H0 → Z Z∗ → 4l
• g∗ + g∗ → H0 → W+W− → e±μ∓νν̄

• g∗ + g∗ → V + Q + Q̄, where V = γ or V = Z/γ ∗
• q + g → V + q, where V = γ or V = Z/γ ∗
• q + Q → V + q + Q, where V = γ or V = Z/γ ∗
• q + q̄ → V + Q + Q̄, where V = γ or V = Z/γ ∗

The standard spectroscopic notation (2S+1)L(a)
J is used

for intermediate Fock state of heavy quark pair QQ̄ pro-
duced with spin S, orbital angular momentum L , total angu-
lar momentum J and color representation a. In the subpro-
cesses above, the radiative decays χcJ (1P) → J/ψ +γ and
χbJ (3P) → ϒ(3S) + γ are simulated keeping the proper
spin structure of the decay amplitudes. The radiative decays
ψ ′ → J/ψ + π+ + π− or ψ ′ → J/ψ + π0 + π0 can
be generated according to the phase space. Also, the subse-
quent leptonic decays J/ψ → l+l−, ϒ(3S) → l+l− and
ψ ′ → l+l−, Z/γ ∗ → l+l− can be generated optionally.

The present version of pegasus is applicable for Fermilab
Tevatron and CERN LHC processes.

Other program used: qwtplot library (version 6.1.3) [28]
for histogram plotting, vegas routine [29] for multi-dimens-
ional Monte-Carlo integration, stand-alone C++ codes from
MMHT [30] and CTEQ [31] groups to provide access to
the MSTW’2008, MMHT’2014, CT’14 and CTEQ6.6 parton
density functions (implemented into the program package).
Downloadof the program:https://theory.sinp.msu.ru/dokuwi
ki/doku.php/pegasus/download.

2 Theoretical framework

Here we present a short review of ideas and frameworks
which form the theoretical basis of pegasus. For more infor-
mation we address the reader to reviews [1–4].

2.1 Kinematics and cross section formula

pegasus operates in the general framework of conventional
Parton Model extended to kT -factorization approach [32–
35]. It employs the factorization hypothesis to calculate the
cross section of a physical process through the convolution
of the (TMD or collinear) parton densities and hard scatter-
ing amplitudes. By default, the kT -factorization scheme is
assumed and can be switched to the collinear QCD factor-
ization for each of colliding particles.

pegasus refers to 2 → 1, 2 → 2 and 2 → 3 partonic
subprocesses. The initial partonic state is described with
Sudakov variables, namely, the light-cone momentum frac-
tions x1 and x2 and non-zero parton transverse momenta k1T

and k2T . The n-particle final state phase space is parameter-
ized in terms of particle rapidities yi , transverse momenta
piT , and azimutal angles φi , where i = 1 . . . n [36]. The
fully differential cross section reads

dσ(pp → p1 · · · pn + X) = π

ŝ F
(4π)2−2n

×
∑
a,b

∑
spin

∑
colors

|Aab(k1k2 → p1 · · · pn)|2 ×

× fa(x1,k2
1T , μ2) fb(x2,k2

2T , μ2)dk2
1T dk

2
2T dp

2
1T

· · · dp2
(n−1)T dy1 · · · dyn dφ1

2π
· · · dφn−1

2π
, (1)

where the 4-momenta for all particles are given in paren-
theses, ŝ = (k1 + k2)

2 is the subprocess invariant energy,
F is the flux factor (see below) and μ2 is the factorization
scale. The longitudinal momentum fractions x1 and x2 are not
the integration variables; they are obtained from the energy-
momentum conservation laws in the light-cone projections:

x1
√
s =

n∑
i=1

miT exp(yi ), x2
√
s =

n∑
i=1

miT exp(−yi ),

(2)
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wheremiT is the transverse mass of produced particle i . In the
optional choice of collinear QCD factorization, we replace
the TMD parton densities with conventional distributions,
omit the integration over k2

1T and k2
2T and take the on-shell

limit in the scattering amplitude Aab as described below.

2.2 Off-shell partonic amplitudes

The calculation of partonic amplitudes follows the standard
Feynman rules, with the exception that the initial gluons are
off-shell.

Off-shell gluons may have nonzero transverse momentum
and an admixture of longitudinal component in the polariza-
tion vector. In accordance with the kT -factorization prescrip-
tions, the initial gluon spin density matrix is taken in the form
[34,35]:

∑
εμ
g ε∗ν

g = kμ
T k

ν
T /|kT |2. (3)

In the collinear limit, when kT → 0, this expression con-
verges to the ordinary

∑
ε
μ
g ε∗ν

g = −gμν/2. This property
provides continuous on-shell limit for the partonic ampli-
tudes.

In general, off-shell initial states may cause violation of
gauge invariance in the non-abelian theories. We solve this
problem in a way [33]. We start with a set of “extended” dia-
grams, where the off-shell gluons are considered as emitted
by on-shell external fields (say, quarks), so that they represent
internal lines in the Feynman graphs. As all of the external
lines in these graphs are on shell, the gauge invariance of the
whole set is fulfilled. However, the extended gauge invari-
ant set may contain unfactorizable diagrams that cannot be
represented as a convolution of the hard scattering ampli-
tude and gluon density functions (such as, for example, Fig.
5e, d in [33]). At the same time, we learn from [33] that
the non-factorizable diagrams vanish in the particular gauge
(3). Therefore, within this gauge, we are left with the usual
diagrams of the Parton Model.

In fact, the prescription (3) is a remake of Equivalent Pho-
ton Approximation (EPA) in QED and DIS. Consider a pho-
ton emitted by an electron: e(p) → e′(p′)+γ (k). Then, tak-
ing trace over the electron line in the matrix element squared
one obtains the polarization tensor

Lμν = tr
[
( p̂′ + me) γ μ ( p̂ + me) γ ν

]

= 8 pμ pν − 4(pk) gμν. (4)

Neglecting the second term in the right hand side in the
small x limit, p � k, one immediately arrives at the spin
structure

∑
εμε∗ν ∼ Lμν ∼ pμ pν . It can be rewritten in the

form (3) after using the Sudakov representation k = xp+kT
and applying a gauge shift εμ → εμ − kμ/x . The gauge
invariance of the matrix element is correct to the accuracy of
O(x) 	 10−4 − 10−6.

2.3 CCFM evolution equation

The CCFM evolution equation [8–11] for TMD gluon den-
sity resums both BFKL [5–7] large logarithms αn

s lnn 1/x
and αn

s lnn 1/(1 − x) terms. In the limit of asymptotic ener-
gies, it is almost equivalent to BFKL, but also similar to
usual DGLAP evolution [12–15] for large x . Moreover,
it introduces angular ordering condition to treat correctly
gluon coherence effects. In the leading logarthmic approxi-
mation (LLA), the CCFM equation for TMD gluon density
fg(x,k2

T , μ2) can be written as

fg(x,k2
T , μ2) = f (0)

g (x,k2
T , μ2

0)
s(μ,μ0)

+
∫

dz

z

∫
dq2

q2 �(μ − zq)
s(μ, zq)P̃gg(z,k2
T , q2)

× fg

(
x

z
,k′ 2

T , q2
)

, (5)

where k′
T = q(1 − z)+kT and P̃gg(z,k2

T , q2) is the CCFM
splitting function:

P̃gg(z,k2
T , q2) = ᾱs(q

2(1 − z)2)

[
1

1 − z
+ z(1 − z)

2

]
+

+ᾱs(k2
T )

[
1

z
− 1 + z(1 − z)

2

]

ns(z,k2

T , q2). (6)

The Sudakov and non-Sudakov form factors read:

ln 
s(μ,μ0) = −
μ2∫

μ2
0

dμ′ 2

μ′ 2

1−μ0/μ′∫

0

dζ

× ᾱs(μ
′ 2(1 − ζ )2)

1 − ζ
, (7)

ln 
ns(z,k2
T ,q2

T ) = −ᾱs(k2
T )

1∫

0

dz′

z′

∫
dq2

q2

×�(k2
T − q2)�(q2 − z′ 2q2

T ). (8)

where ᾱs = 3αs/π . The first term in the CCFM equation
is the initial TMD gluon density f (0)

g (x,k2
T , μ2

0) multiplied
by the Sudakov form factor, decribing the contribution of
non-resolvable branchings between the starting scale μ2

0 and
scale μ2. The second term represents the details of the QCD
evolution expressed by the convolution of the CCFM gluon
splitting function P̃gg(z,k2

T , q2) with the gluon density and
Sudakov form factor. The angular ordering condition is intro-
duced with the theta function, so the evolution scale μ2

is defined by the maximum allowed angle for any gluon
emission [8–11]. The main advantage of this approach is
the implicit including of higher-order radiative corrections
(namely, a part of NLO + NNLO + · · · terms corresponding
to the initial state real gluon emissions). Some details can be
found, for example, in reviews [2–4].
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A similar equation can be also written [37] for TMD
valence quark densities with replacement of the gluon split-
ting function by the quark one.1 One usually takes the initial
TMD gluon and valence quark distributions as

f (0)
g (x,k2

T , μ2
0) = Nx−B(1 − x)C exp(−k2

T /σ 2), (9)

f (0)
qv

(x,k2
T , μ2

0) = xqv(x, μ
2
0) exp(−k2

T /σ 2)/σ 2, (10)

where σ = μ0/
√

2 and qv(x, μ2) is the conventional
(collinear) quark density function. The parameters N , B and
C can be fitted from collider data (see [37]).

The TMD (valence) quark densities for CCFM approach
are not available in the current version of the pegasus.

2.4 Parton Branching approach

The Parton Branching (PB) method [39,40] allows one to
solve the DGLAP equations iteratively. It gives a possibility
to take into account simultaneously soft-gluon emission at
z → 1 and transverse momentum qT recoils in the parton
branchings along the QCD cascade. The latter leads to a nat-
ural determination of TMD density functions for both gluons
and quarks. A soft-gluon resolution scale zM is introduced
to separate resolvable and non-resolvable emissions, which
are treated via the DGLAP splitting functions Pab(αs, z) and
Sudakov form-factors, respectively. The PB equations for
TMD parton densities read:

fa(x,k2
T , μ2) = f (0)

a (x,k2
T , μ2

0)
a(zM , μ2, μ2
0)

+
∑
b

zM∫

x

dz
∫

d2q
πq2 �(μ2 − q2) ×

×�(q2 − μ2
0)


a(zM , μ2, μ2
0)


a(zM ,q2, μ2
0)

P(R)
ab (αs(q2), z)

× fb

(
x

z
,k′ 2

T , q2
)

, (11)

where a = q or g and k′
T = q(1 − z) + kT . The Sudakov

form factors are defined as

ln 
a(zM , μ2, μ2
0)= −

∑
b

μ2∫

μ2
0

dμ′ 2

μ′ 2

zM∫

0

dζ ζ P(R)
ba (αs (μ

′ 2), ζ ). (12)

The real-emission branching probabilities P(R)
ab are obtained

from splitting functions Pab by eliminating δ(1 − z)-terms
and substituting 1/(1−z)+ → 1/(1−z). The evolution scale
μ2 can be connected with the emission angle with respect to

1 The TMD sea quark densities are not defined in CCFM approach.
However, they can be obtained from the gluon ones in the last gluon
splitting approximation [38].

the beam direction, that leads to the angular ordering con-
dition μ = |qT |/(1 − z). The dependence on the zM diss-
apears when this angular ordering condition is applied and
zM is large enough. The initial TMD parton distributions
are taken in a factorized form as a product of conventional
quark and gluon densities and intrinsic transverse momen-
tum distributions (taken in gaussian form [18,24,25]), where
all the parameters can be fitted from the collider data. Unlike
the CCFM, the PB densities have the strong normalization
property:

μ2∫

0

fa(x,k2
T , μ2)dk2

T = xa(x, μ2), (13)

where a = q or g and xa(x, μ2) are the conventional parton
density functions (PDFs). The PB equations can be solved
numerically by an iterative Monte-Carlo method with the
leading order (LO) or next-to-leading order (NLO) accuracy.
The solution results in a steep decline of the parton densities
at k2

T > μ2. It contrasts the CCFM evolution, where the
transverse momentum is allowed to be larger than the scale
μ2, corresponding to an effective taking into account higher-
order contributions.2

2.5 Kimber–Martin–Ryskin approach

The Kimber-Martin-Ryskin (KMR) approach [42,43] pro-
vides a technique to construct TMD gluon and quark densi-
ties from conventional ones by loosing the DGLAP strong
ordering condition at the last evolution step, that results in
kT dependence of the parton distributions. This procedure
is believed to take into account effectively the major part
of next-to-leading logarithmic (NLL) terms αs(αs ln μ2)n−1

compared to the LLA, where terms proportional to αn
s lnn μ2

are taken into account.
At the LO, the KMR method, defined for k2

T ≥ μ2
0 ∼

1 GeV2, results in expressions for TMD quark and gluon
distributions [42,43]:

fq (x,k2
T , μ2) = Tq (k2

T , μ2)
αs(k2

T )

2π

×
1∫

x

dz

[
PLO
qq (z)

x

z
q

(
x

z
,k2

T

)
�(
 − z) + PLO

qg (z)
x

z
g

(
x

z
,k2

T

)]
,

(14)

fg(x,k2
T , μ2) = Tg(k2

T , μ2)
αs(k2

T )

2π

×
1∫

x

dz

[∑
q

PLO
gq (z)

x

z
q

(
x

z
,k2

T

)
+ PLO

gg (z)
x

z
g

(
x

z
,k2

T

)
�(
 − z)

]
,

(15)

2 Very recently, a method to incorporate CCFM effects into the PB
formulation has been proposed [41].
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where PLO
ab (z) are the usual DGLAP splitting functions at LO

and μ2
0 is the minimum scale for which DGLAP evolution

is valid. The theta functions introduce the specific ordering
conditions in the last evolution step, thus regulating the soft
gluon singularities. The cut-off parameter 
 usually has one
of two forms, 
 = μ/(μ+|kT |) or 
 = |kT |/μ, that reflects
the angular or strong ordering conditions, respectively. In the
case of angular ordering, the parton densities are extended
into the k2

T > μ2 region, whereas the strong ordering condi-
tion leads to a steep drop of the parton distributions beyond
the scale μ2. At low k2

T < μ2
0 the behaviour of the TMD

parton densities has to be modelled [42,43]. Usually it is
assumed to be flat under strong normalization condition (9).

The Sudakov form factors allow one to include logarith-
mic virtual (loop) corrections, they take the form:

Tq (k2
T , μ2) = exp

⎡
⎢⎢⎣−

μ2∫

k2
T

dq2
T

q2
T

αs (q2
T )

2π

zmax∫

0

dζ PLO
qq (ζ )

⎤
⎥⎥⎦ , (16)

Tg(k2
T , μ2) = exp

⎡
⎢⎢⎣−

μ2∫

k2
T

dq2
T

q2
T

αs (q2
T )

2π

×
⎛
⎜⎝

zmax∫

zmin

dζ ζ PLO
gg (ζ ) + n f

1∫

0

dζ PLO
gq (ζ )

⎞
⎟⎠

⎤
⎥⎦ , (17)

with zmax = 1 − zmin = μ/(μ + |qT |). These form factors
give the probability of evolving from a scale k2

T to a scale
μ2 without parton emission. At the NLO, the TMD parton
densities can be written as [40]:

fa(x,k2
T , μ2) =

1∫

0

dz Ta(p2
T , μ2)

αs(p2
T )

2π

×
∑
b=q,g

PNLO
ab (z)

x

z
b

(
x

z
,p2

T

)
�(
 − z), (18)

where p2
T = k2

T /(1 − z). Note that both DGLAP splitting
functions and conventional parton distributions should be
taken with NLO accuracy. The Sudakov form factors at NLO
read:

Tq(k2
T , μ2) = exp

⎡
⎢⎢⎣−

μ2∫

k2
T

dq2
T

q2
T

αs(q2
T )

2π

1∫

0

dζ ζ

× (PNLO
qq (ζ ) + PNLO

gq (ζ ))

⎤
⎥⎥⎦ , (19)

Tg(k2
T , μ2) = exp

⎡
⎢⎢⎣−

μ2∫

k2
T

dq2
T

q2
T

αs(q2
T )

2π

1∫

0

dζ ζ

× (PNLO
gg (ζ ) + 2n f P

NLO
qg (ζ ))

⎤
⎥⎥⎦ . (20)

However, it was demonstrated that the NLO prescription,
with a good accuracy, can be significantly simplified to keep
only the LO splitting functions [44] while the main effect is
related to the Sudakov form factors.

2.6 Flux factor

The choice of the flux factor is another peculiarity of off-
shell calculations. The definition of the flux, which is the
velocity of an off-shell particle, is highly disputable and is
not clear. By default, we accepted the analytic continuation
of the general textbook definition [36]:

F = 2λ1/2(ŝ, k2
1, k2

2). (21)

Our choice is supported by a numerical experiment [45],
where we have considered the production of χcJ states in
a two photon process, e + e → χcJ + e′+e′ and made a
comparison between the prompt calculation of this 2 → 3
process and calculation based on EPA, γ + γ → χcJ with
J = 0, 1 or 2. We find that the flux taken in the form (21) pro-
vides a sensibly better fit to the exact calcualtion. The fact that
the exact calculation disagrees with the factorized (collinear)
calculation indicates that the conditions for the factorization
theorem are yet not fulfilled. In such a situation, our choice
of the flux can be regarded as a phenomenological correction
for non-factorizable contributions. The same definition of the
flux is adopted, for example, in [26]. However, the user can
optionally choose the conventional definition F = 2x1x2s,
as it is explained below.

3 Calculations using PEGASUS

pegasus has an intuitive and extremely user friendly inter-
face. The calcualtions using pegasus include a few general
steps common for all of the processes. So, when pegasus is
running, one can select the colliding particles, pp or p p̄, and
set their center-of-mass energy

√
s. The default setting corre-

sponds to the LHC Run II setup. Then one can select factor-
ization scheme (TMD or collinear one) for each of the collid-
ing particles, choose corresponding parton density function
and set the parameters, important for further Monte-Carlo
simulation, namely, number of iterations and number of sim-
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Fig. 1 pegasus main window. Here one can select factoriza-
tion scheme (TMD or collinear one) for each of the collid-
ing particles, choose corresponding parton density function and

set the parameters, important for further Monte-Carlo simula-
tion: number of iterations and number of simulated events per
iteration

ulated events per iteration (see Fig. 1). Next steps could be
as follows (note that all these steps do not depend on each
other and can be done in different order):

• From the list of available processes one can select the nec-
essary process and then (optionally) correct the default
kinematical restrictions, hard scales, list of requested
observables and corresponding binnings (see Figs. 2, 3,
4). This can be done by double clicking on the requested
process or via main menu (using Edit → Task option).

• For each of the observables one can manually edit the
default binning according to own wishes. As another
option, the binning can be uploaded immediately from
the data file. Several commonly used formats (such as
.yoda, .yaml, .csv or plain data format, compatible
with gnuplot [46] tool) as provided by HepData repos-
itory [47] are supported.

• The user-defined setup for any process (total center-
of-mass energy, selected parton densities, kinematical
restrictions, binnings etc) can be saved to a configura-
tion file in some internal format (*.pegasus). This
can be done via the main menu (using File → Save or
File → Save As options) or via the popup menu available

on right mouse button click or via appropriate button in
the button panel. Of course, the configuration file can be
loaded and a user-defined setup can be used in further
applications. This can be done via main menu (with File
→ Open option) or via popup menu or via Open button
on the button panel.

• Weighted or unweighted events can be generated. This
option is available via main menu Edit → Settings →
Generated events or via popup menu.

• If one needs to generate the Les Houches Event file [48],
one has to mark corresponding option before the calcu-
lation starts (see Fig. 1). Note that this option affects the
speed of the calculations.

• The calculation will start by choosing the corresponding
option in main menu (Calculation → Start), popup menu
or pressing Start button on the button panel. The numeri-
cal results for requested observables will be immediately
presented “on the fly” with built-in tool pegasus plot-
ter (see Fig. 5). The calculations can be paused or even
stopped (using main menu options Calculation → Pause,
Calculation → Stop, corresponding buttons on the button
panel or options in popup menu). Of course, during pause

123



Eur. Phys. J. C (2020) 80 :330 Page 7 of 16 330

in the calculations, all manipulations with accumulated
results in pegasus plotter are allowed (see Sect. 4.3).

• If there are several contributing subprocesses, there is
a possibility to immediately jump to the next one (via
Calculation → Next option in main menu or appropri-
ate button on button panel or popup menu) during the
calculations.

The generated events can be accumulated in Les Houches
Event (*.lhe) file and/or presented in pegasus plotter.
Using the latter, one can save the results in a some internal
format (*.pplot) or as a simple plain data (compatible, for
example, with gnuplot package) or export them to an image
(*.pdf, *.png, *.jpg or *.bmp).

Below we give a more detailed information and explana-
tions about the important features of pegasus.

3.1 Parton density functions in a proton

Latest sets [37] of CCFM-evolved TMD gluon distributions
in a proton, JH’2013 set 1 and JH’2013 set 2, are available
in the pegasus. The input parameters of JH’2013 set 1 were
determined from the fit to high precision HERA data on the
proton structure function F2(x, Q2), whereas the parameters
of JH’2013 set 2 gluon were extracted from combined fit on
both F2(x, Q2) and Fc

2 (x, Q2) data (see [37]). The previous
CCFM fits, namely, A0 and B0 sets [49], are available also
and comparison between them can be found [37]. Techni-
cally, all these CCFM-evolved gluon densities are stored on
a grid in log x , log kT and log μ and a simple linear interpo-
lation is applied to evaluated the gluon density for values in
between the grid points. This interpolation proceeds automat-
ically at the each event generation. The data files containing
the grid points are supplied with the program package and
read in at the beginning of each requested calculation.3

The TMD gluon and quark densities can be also evalu-
ated in the standard DGLAP scenario using the PB and/or
KMR schemes (with LO or NLO accuracy). As an input
for the KMR procedure, the conventional (collinear) PDFs
have to be applied. Several sets of KMR and PB-based
gluon densities are currently available in pegasus. So, well
known NNPDF3.1 (LO) [51] and MMHT’2014 (LO) [30]
parametrizations and recent analytical expressions obtained
[52–54] in the so-called generalized double asymptotic scal-
ing (DAS) approximation of QCD [53,54] were used as an
input. The DAS approximation is connected to the asymp-
totic behaviour of the DGLAP evolution discovered many

3 We would like to note that, in the case of CCFM equation, the TMD
gluon distribution can be derived from a forward evolution procedure
as implemented in the updfevolv routine [50]. From the initial gluon
density as given by (9), which includes a Gaussian intrinsic kT distribu-
tion, a set of values x and kT can be obtained by evolving up to a given
scale μ. The input parameters in (9) have to be fitted from the data.

years ago [55]. Flat initial conditions for the DGLAP equa-
tions, applied in the generalized DAS scheme, lead to the
Bessel-like behaviour for the proton PDFs at small x [53,54].
The DAS LO set 1 corresponds to “frozen” treatment of
the QCD strong coupling in the infrared region: αs(μ

2) →
αs(μ

2 +m2
ρ). The DAS LO set 2 is based on the idea [56,57]

regarding the analyticity of the strong coupling at low scales.
The difference between these two choices is discussed [58].
Everywhere, the cut-off parameter 
 is taken according to
angular ordering condition.

The available TMD gluon sets with the essential param-
eters are listed in Table 1. We note that large variety of the
TMD gluon distribution functions in a proton are collected in
the tmdlib package [27], which is a C++ library providing a
framework and an interface to the different parametrizations.

To perform the calculations in the collinear QCD factor-
ization (mainly at LO or tree-level NLO for some processes)
several sets of conventional PDFs are available in pega-
sus. These are recent MMHT’2014 (LO and NLO) [30] and
CT14 (LO and NLO) [59] ones and previous sets provided
by CTEQ Collaboration (CTEQ’6.6) [60], MSTW’2008 (LO
and NLO) [61] and GRV’94 (LO) [62]. The standalone C++
codes from MMHT [30] and CTEQ [31] groups are imple-
mented into the pegasus code and corresponding data files
containing the grid points are supplied with the program
package.

3.2 Simulated processes

List of processes, currently available in the pegasus, is pre-
sented in Table 2. We would like to clarify some points, which
are not mentioned in the Table 2:

• Q denotes a heavy (c or b) quark, Q denotes Bc, B
(∗)
c ,

J/ψ , ψ ′, ϒ(3S), χcJ (1P) or χbJ (3P) mesons with J =
0, 1 or 2, V stands for γ or Z/γ ∗ and l = e or μ.

• The standard spectroscopic notation (2S+1)L(a)
J is used

for intermediate Fock state of heavy quark pair QQ̄ pro-
duced with spin S, orbital angular momentum L , total
angular momentum J and color representation a.

• Besides the scales, listed in the Table 2, for every process
some universal scales are available, namely: total energy
of the partonic subprocess

√
ŝ, also

√
ŝ/4 and so-called

CCFM scale
√
ŝ + Q2

T [37,49], where QT is the total
tranverse momentum of the final partons, see Fig. 3.

• To estimate the scale uncertainties, the hard scales above
can be varied around its default value by a factor of 2
or 1/2, as it often done in the pQCD calculations. This
applies to any scale, except the CCFM scale. For CCFM-
based gluon densities the scale uncertainties are evaluated
by a change of the default gluon distribution to so-called
“+” and “–” ones of the corresponding set [37,49].
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Table 1 The TMD gluon
densities in a proton
implemented into the pegasus.
The A0±, B0±, JH’2013 set 1±
and JH’2013 set 2±
distributions, needed to estimate
the scale uncertainties of the
calculations (see below), are not
shown

Set Order of αs N f �QCD/MeV References

A0 (CCFM) 1 4 250 [49]

B0 (CCFM) 1 4 250 [49]

JH’2013 set 1 (CCFM) 2 4 200 [37]

JH’2013 set 2 (CCFM) 2 4 200 [37]

KMR (MMHT’2014 LO) 1 5 211 [42,43]

KMR (NNPDF3.1 LO) 1 5 167 [42,43]

KMR (DAS LO set 1) 1 4 143 [58]

KMR (DAS LO set 2) 1 4 143 [58]

PB-NLO-HERAI+II’2018 set 1 2 4 118 [40]

PB-NLO-HERAI+II’2018 set 2 2 4 118 [40]

Table 2 List of the available processes. Note that exact definitions of all kinematical variables can be found, for example, in corresponding
references

Process Subprocesses Scales Observables References

Open heavy flavor production g∗ + g∗ → Q + Q̄ pT (Q) pT (Q) [63]

• Charm mT (Q) y(Q)

• Beauty M(QQ̄)


φ(QQ̄)

Double flavored bound state g∗ + g∗ → Q + b + c̄ pT (Q) pT (Q) [64]

Production mT (Q) y(Q)

• Bc

• B(∗)
c

S-wave heavy quarkonia g∗ + g∗ → QQ̄[3S(1)
1 ] + g → Q + g pT (Q) pT (Q) [65,66]

Production g∗ + g∗ → QQ̄[1S(8)
0 ] → Q mT (Q) y(Q)

• J/ψ g∗ + g∗ → QQ̄[3S(8)
1 ] → Q

• ψ ′ g∗ + g∗ → QQ̄[3P(8)
J ] → Q

• ϒ(3S)

P-wave heavy quarkonia g∗ + g∗ → QQ̄[3P(1)
J ] → Q pT (Q) pT (Q) [65,66]

Production g∗ + g∗ → QQ̄[3S(8)
1 ] → Q mT (Q) y(Q)

• χcJ (1P)

• χbJ (3P)

Inclusive Higgs production g∗ + g∗ → H0 m(H0) pT (H0) [67]

• H0 → γ γ mT (H0) y(H0)

• H0 → Z Z∗ → 4l | cos θ∗|
• H0 → W+W− → e±μ∓νν̄ 
φ(γ γ )

m34(ll)

y(ll)

Associated gauge boson and g∗ + g∗ → V + Q + Q̄ pT (γ ) pT (V ) [68,69]

heavy flavor production g + Q → V + Q pT (Q) pT (Q)

• γ + Q q + Q → V + q + Q m(Z/γ ∗) y(V )

• Z/γ ∗ + Q q + q̄ → V + Q + Q̄ mT (Z/γ ∗) y(Q)


R(ZQ)


φ(ZQ)
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Fig. 2 One can optionally correct the default kinematical restrictions, list of requested observables and corresponding binnings for any processes
(part 1)

• Part of the non-logarithmic loop corrections to effective
g∗ + g∗ → H0 vertex can be absorbed in the special
K -factor [70] and optionally implemented into the cal-
culations. As default choice, this K -factor is switched
off.

• According to experimental setup, an isolation criterion
is applied for prompt photon production. This criterion
is the following: a photon is isolated if the amount of
hadronic transverse energy Ehad

T deposited inside a cone
with aperture R centered around the photon direction in
the pseudo-rapidity and azimuthal angle plane, is smaller
than some value Emax

T (“cone isolation”). The isolation
requirement significantly (up to ∼ 10% of the visible
cross section) reduces contribution from the so-called
photon fragmentation mechanisms, not implemented into
the pegasus. The isolation criterion and additional con-
ditions which preserve our calculations from divergences
have been specially discussed, for example, in [71] (see
also references therein). The default values R = 0.4 and
Emax
T = 4 GeV can be changed optionally.

• At present, quark-initiated subprocesses can be calcu-
lated only within collinear QCD factorization and no
TMD quark densities are implemented into the current
version of pegasus. The QCD Compton subprocess is
available only, if collinear factorization has been chosen,

since in the kT -factorization approach its contribution is
taken into account by the off-shell gluon-gluon fusion
(see [68,69] for more details).

3.3 Quarkonium final states

Quarkonium production processes need additional explana-
tions as they contain an important extra step: the formation
of bound states.

The process starts with the production of a heavy quark-
antiquark pair QQ̄ in a hard parton interaction. The produced
quark pair may be either color singlet or color octet. If the
QQ̄ state is color singlet, it can immediately convert into
a meson with appropriate quantum numbers. Then the for-
mation probability is determined by a single parameter, the
radial wave function at the origin of the coordinate space,
|RS(0)|2 or |R′

P (0)|2 [72–76]. The values of these functions
can be extracted from the measured decay widths or calcu-
lated within potential models.

The situation with color-octet states is more complicated
as the transition to a color-singlet physical hadron requires
the emission of extra (soft) gluons. Then, for every final state
hadron h and for every intermediate QQ̄ state n = 2S+1L J

listed in Table 2 there is a specific phenomenological long-
distance matrix element (LDME) [77–80] responsible for
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Fig. 3 One can optionally correct the default kinematical restrictions, list of requested observables and corresponding binnings for any processes
(part 2)

such a transition 〈Oh [n]〉. Eventually, the production cross
section for a hadron h in pp collisions is given by a sum over
all possible singlet and octet QQ̄ states:

σ(pp → h + X) =
∑
n

σ
(
pp → QQ̄ [n]

) 〈Oh [n]〉, (22)

where σ
(
pp → QQ̄ [n]

)
is the partial partonic cross sec-

tion (1) for a QQ̄ state n. The different states n are selected
by introducing the proper projection operators in the hard
scattering amplitude. The correspondence between the color
singlet and color octet wave functions and respective LDMEs
is given by the 〈Oh

[
2S+1L J

]〉 = 2Nc(2J +1)|RS(0)|2/4π

and 〈Oh
[

2S+1L J
]〉 = 6Nc(2J + 1)|R′

P (0)|2/4π , respec-
tively.

As default choice to describe the spin structure of relevant
transition amplitudes, pegasus uses the model [81], where
the NRQCD emission of soft gluons is considered in terms
of classical multipole radiation theory. The multipole expan-
sion is dominated by (chromo)electric dipole transitions E1.
According to [81], only a single E1 transition is needed to
transform a P-wave state into an S-wave state and the struc-
ture of the respective 3P(8)

J → 3S(1)
1 + g amplitudes is taken

the same as for radiative decays of χcJ mesons [82,83]:

A( 3P(8)
0 → 3S(1)

1 + g) ∼ kμ pμ εν(l)ε
ν(k), (23)

A( 3P(8)
1 → 3S(1)

1 + g) ∼ eμναβkμ εν(p) εα(l)εβ(k),

(24)

A( 3P(8)
2 → 3S(1)

1 + g) ∼ pμ εαβ(p) εα(l)

[kμεβ(k) − kβεμ(k)], (25)

where p, k and l = p− k are the four-momenta of the color-
octet P-wave state, emitted gluon and produced color-singlet
S-wave state, εμ(k), εμ(l), εμ(p) and εμν(p) are the polar-
ization vectors (tensor) of respective particles and eμναβ is
the fully antisymmetric Levi–Civita tensor. The transforma-
tion of an S-wave state into another S-wave state (such as
J/ψ or ψ ′ meson) is treated as two successive E1 transi-
tions 3S(8)

1 → 3P(8)
J + g, 3P(8)

J → 3S(1)
1 + g proceeding

via either of the three intermediate states: 3P(8)
0 , 3P(8)

1 , or
3P(8)

2 . For each of the two transitions the same effective cou-
pling vertices (24)–(25) are exploited. In the case of J/ψ or
ϒ(3S) production, the user can optionally include feed-down
from the decays of upper quarkonium states (ψ ′, χcJ (1P) or
χbJ (3P), respectively) in addition to the direct production
channels.

The absolute normalization of the transition amplitudes
is not calculable within the theory; these numbers are taken
as free adjustable parameters. However, the values of the
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Fig. 4 One can optionally correct the default kinematical restrictions, list of requested observables and corresponding binnings for any processes
(part 3)

LDMEs for the different partial contributions are not com-
pletely independent but are connected by the heavy quark
spin symmetry (HQSS) relations [79,80]. All the HQSS
relations between LDMEs are implemented in the pegasus
default setting, taken from [65,66].

3.4 Strong coupling and masses of particles

In pegasus, the strong coupling αs can be calculated in one-
loop or two-loop approximation with respect to the number
of active flavors N f and �QCD. The choice of N f and �QCD

is done automatically (according to the Table 1) with the
choice of the TMD and/or conventional parton density in a
proton. There is no possibility to change it manually since this
setup is essential for determination of corresponding parton
distributions.

The masses of all particles (quarks, gauge bosons, heavy
quarkonia etc), their branching ratios and decay widths are
fixed according to Particle Data Group (PDG) [84]. Any of
these parameters can be easily changed using the convenient
built-in particle data tool (see Fig. 5), which is available
via main menu (Edit → Settings → Particle data) or popup
menu or appropriate button on the button panel.

3.5 Generation of Les Houches Event file

pegasus is supplied with a tool to construct event files in the
Les Houches Event format [48]. This is a widely accepted
format to present events, which is compatible with the major-
ity of modern general purpose Monte-Carlo generators.

The Les Houche Event (LHE) file, generated by the pega-
sus, consists of two main blocks: the first one contains the
information about the number of the recorded events, the
PDFs used, the colliding hadrons and their energies. Also
the total cross section is shown. The second block represents
a list of events, including the data on the interacting partons,
their 4-momenta and color structure of the event. We mention
the basic features of the LHE file, generated by the pegasus:

• The generated events could be weighted or unweighted.
In first case, the sum of all the weights is the total cross
section of the subprocess.

• Polarization information is not preserved.
• A parton carries a tag according to the standard PDG

numbering scheme [84].
• Conventional (collinear) parton densities in a proton are

numbered according to the lhapdf scheme [85] while
TMD parton distributions are numbered according to the
tmdlib package [27].
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Fig. 5 Particle data tool can be launched from pegasus main window

The produced LHE file can then be processed with an
external program to introduce some peculiar event selection,
to include parton showers, to hadronize the final particles, etc.
It is found to be compatible with such Monte Carlo generators
as pythia [16] and cascade [24,25].

4 Program components

4.1 Random number generator

Since all the internal variables in pegasus are declared as
double precision ones, double precision random numbers
have to be generated in the Monte-Carlo simulations. The
random number generator ranlux [86] is well suited for
these purposes. It has a long period, solid theoretical founda-
tions and is commonly used in computational physics. This
random number generator is implemented into the pegasus.

4.2 Phase space integration and event generation

The multidimensional phase space integration (1) is per-
formed with the Monte-Carlo technique and is incorporated
with the routine vegas [29]. The routine vegas allows up

to ten integration variables, that is enough for subprocesses
considered in pegasus.

The vegas algorithm is based on a method for reducing
statistical errors by using a known probability distribution
function to concentrate the search in those areas of the inte-
grand that make the greatest contribution to the final integral.

The algorithm is realised through a large number of
random sample points distributed over a d-dimensional
rectangular volume. The whole volume is divided into d-
dimensional rectangular cells (by default, 50 divisions along
each axis). The probability for a point to drop into a given
cell is determined by so called sampling distribution, which
is adjusted to the integrand function. The sampling distribu-
tion approximates the exact distribution by making a number
of passes (iterations) over the integration region while his-
togramming the integrand functiondσ given by the expession
(1). Each iteration is used to define a sampling distribution for
the next iteration. To improve the convergence in the region
of high pT , the user can optionally modify the integrand func-
tion from dσ to (1 + p4

T )dσ , see Fig. 1. The optimization
of the sample grid is made automatically and needs no care
from the user.

Each sample point generated byvegas represents an event
in the n-particle phase space with the coordinates of the
sample point responding to the values of the physical inte-
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Fig. 6 Results of the calculations presented by pegasus plotter: open bb̄ production in pp collisions at
√
s = 13 TeV. No kinematical cuts are

applied

gration variables (piT , yi , φi ). The weight attributed to that
event is given by the product of the integrand function dσ

and the d-volume of the sampling cell containing that point,
dw = dσdVcell. Unweighting algorithm for the generated
events is provided also.

The typical time needed to generate one event, of course,
depends on the requested subprocess; but, in general, is sim-
ilar to time needed by other Monte-Carlo event generators
like cascade or pythia. The output events can be plotted
on a histogram (using built-in tool pegasus plotter ) or
stored for further use in the form of an Les Houches Event
file.

4.3 PEGASUS plotter

pegasus is supplied with a built-in tool pegasus plot-
ter, allowing one to depict easily the produced differential
cross sections and immediately compare them with experi-
mental data. As a default setting, the accumulated results for
requested observables during the calculation are shown in
pegasus plotter. However, it is a quite independent tool
and can be used apart from any calculations made within the
pegasus. The program is very simple and intuitive. Let us
briefly describe main features of the tool.

As one calls the pegasus plotter from the main menu
of the pegasus (using the Tool → Plotter option, or via
popup menu, or by pressing the corresponding button on but-
ton panel) an empty sheet is created. The following objects,
stored in a plain data files, could be added to the sheet (by
choosing Edit → Add option in the main menu or popup
menu available with a right mouse button click on the sheet):

• Curve. The data file should consist of two columns, cor-
responding to the rows of x and y values.

• Histogram. The data file is the same, as for Curve. How-
ever, every y value should be mentioned twice, for the
both borders of the corresponding bin.

• Filled area. A three-columns data file should contain for
every x value lower and upper values of y.

• Text label. An arbitrary text note inside the plot sheet.
Greek letters are available through the syntax{/Symbol
letter}, where the letter is just the name of the
greek symbol (for instance, alpha, sigma or other).
Several capital greek symbols are available, namely, ϒ

({/Symbol Upsilon}), � ({/Symbol Psi}) and 


({/Symbol Delta}). Subscripts and superscripts are
available with a latex-like syntax _{subscript},
ˆ{superscript}.
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Fig. 7 Results of the calculations presented by pegasus plotter:
inclusive Higgs production (in W+W− decay mode) in pp collisions
at

√
s = 8 TeV. The filled areas correspond to the scale uncertainties

estimated for JH’2013 set 2 gluon density. Experimental data are from
ATLAS Collaboration [87]. The kinematical cuts are exactly the same
as described in ATLAS paper

• Experimental data. The data file should be in gnuplot-
compatible format with 6 columns, corresponding to x ,
y, lower and upper x values and lower and upper y val-
ues. Alternatively, the data files in standard *.yoda or
*.csv format (available from HepData repository [47])
can be uploaded.

As an object is added on the sheet, it can be selected with
a left mouse button click and modified according to user own
wishes either with a double click or with choosing option
Edit → Plottable in the pegasus plotter main menu or via
popup menu. Then the text label in the legend and appearance
of the selected object (for example, color, font, size etc) can be
changed. If selected object is a Histogram, the fiducial cross
section (integral with respect to the x variable) is shown in
the status bar. One can also set a factor to scale the depicted
cross sections using Edit → Multiply by a factor option in
main menu or popup menu.

The default axes setting can be changed from the main
menu (Edit → Axes option) or by double clicking an axis.
Besides the font, alignment and other setting one can also
set the axes to be linear or logarithmic. From the main menu

(Options → Plot size) or popup menu one can also adjust the
size of the graph in pixels.

The plot can be saved for the future editing via main menu
options File → Save or File → Save As or via popup menu
in the internal format (*.pplot). The export to a gnuplot
script is possible via main menu Export → Plot to Gnu-
plot script option or via popup menu. The figure can be also
printed out or saved in *.png, *.jpg or *.bmp format.
Finally, samples for all plotted curves, histograms or data
point sets (or for only selected ones) can be transfered (using
Options → Export) to a plain data file (which is compati-
ble, for example, with gnuplot) for future usage in other
programs.

Some typical snapshots of the pegasus plotter are pre-
sented on Figs. 6 and 7. So, here we illustrate the TMD
effects in open beauty production at

√
s = 8 TeV (Fig. 6)

and present some results for inclusive Higgs production (in
W+W− decay mode) compared with the ATLAS data [87]
(Fig. 7). Note that in the latter case all the kinematical cuts
applied and binnings are exactly the same as described in the
ATLAS paper [87].

123



Eur. Phys. J. C (2020) 80 :330 Page 15 of 16 330

5 Installation and running

pegasus can be downloaded from https://theory.sinp.msu.
ru/dokuwiki/doku.php/pegasus/download as a precompiled
executive file for Linux machines. No special installa-
tion procedure is needed. However, please be sure that
g++ and gfortran are already installed in your system
(to be precise, libc.so.6, libgfortran.so.3 and
libstdc++.so.6 are needed). The data files containing
the necessary TMD parton densities in a proton (and conven-
tional PDFs as well) are located inside the pegasus home
directory (folder data). If there are some missing data files
in data folder, pegasus will inform user about that. In this
case, no calculation is allowed. Location of data folder
could be easily changed via main menu option Edit → Set-
tings → Path to data folder.

For Linux machines, the executive file can be just run
from a terminal as ./PEGASUS. The program demands
the qwt library (version 6.1.3) [28], so the library file
libqwt.so.6 should be inside the pegasus home direc-
tory. Otherwise, the path to this file should be specified with
export LD_LIBRARY_PATH=/path/to/library. If
a long-time calculation is needed, one can run console version
as ./cPEGASUS filename.pegasus with the user-
defined setup saved to a configuration file filename.
pegasus.

The program was tested on ROSA Linux R8.1, ROSA
Linux R11 and Ubuntu 16.04.
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